Service Issue on PayConex platform.
Resolved
This incident has been resolved.
Posted May 22, 2023 - 13:09 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 22, 2023 - 11:23 EDT
Investigating
We have detected a service interruption on our PayConex platform. Our team of engineers is currently working to restore service as soon as possible. Please check back for further updates. We apologize for the inconvenience and we thank you for your patience.
Posted May 22, 2023 - 10:42 EDT
This incident affected: PayConex.