PayConex Software Release

Completed

The scheduled maintenance has been completed.
Posted Jul 02, 2024 - 12:00 EDT

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 02, 2024 - 07:00 EDT

Scheduled

Bluefin will be performing a software maintenance update to the production PayConex environment on Tuesday, July 2, 2024, from 07:00 AM to 12:00 PM EDT.

This maintenance in production is not anticipated to impact service availability.

This software update is currently being deployed in our certification environment. If you experience any issues while testing, please contact our support staff for assistance.
Posted Jun 20, 2024 - 16:24 EDT
This scheduled maintenance affected: PayConex.