Resolved

Update - All Systems Operational
Posted Oct 15, 2025 - 18:58 EDT

Update

Update - The service provider's technical team is still continuing to restore full functionality. We will provide further updates as we receive them.
Posted Oct 15, 2025 - 16:00 EDT

Update

Update - The service provider's technical team is continuing to restore full functionality. We will provide further updates as we receive them.
Posted Oct 15, 2025 - 15:04 EDT

Update

Update - The incident management team continues to investigate the issue as a top priority.
Posted Oct 15, 2025 - 14:19 EDT

Investigating

We want to inform you that our phone system provider is currently experiencing a service disruption affecting both inbound and outbound calling.

In the meantime, you can still reach us via email:
- Technical Support: techsupport@bluefin.com
- Customer Service: service@bluefin.com

We understand the inconvenience this may cause and sincerely appreciate your patience and understanding while the issue is being resolved.
Posted Oct 15, 2025 - 13:10 EDT
This incident affected: Bluefin US.