Intermittent processing issue on PCX - Issue with 3rd party service provider

Resolved

The issue affecting intermittent processing has been resolved. Our third-party service provider has confirmed that services are operating normally, and we have not observed any further impact. We will continue to monitor the environment, but this incident is now considered resolved.
Posted May 29, 2026 - 08:16 EDT

Update

We are continuing to monitor for any further issues.
Posted May 29, 2026 - 05:05 EDT

Update

Our third-party service provider is continuing to investigate the ongoing issue. We are continuing to monitor the situation closely while the provider works to resolve this issue. Further updates will be shared as they become available. https://status.imperva.com/
Posted May 29, 2026 - 02:44 EDT

Update

Our third-party service provider have remain engaged in the investigation of this issue. We are continuing to monitor the situation closely while the provider works toward full resolution. Further updates will be shared as they become available. https://status.imperva.com/
Posted May 28, 2026 - 22:04 EDT

Monitoring

Our third-party service provider has implemented a temporary fix, and processing stability has improved. We are continuing to monitor the situation closely while the provider works toward full resolution. Further updates will be shared as they become available. https://status.imperva.com/
Posted May 28, 2026 - 17:26 EDT

Identified

We are continuing to experience intermittent processing issues related to a third-party service provider. The provider is actively working to resolve the issue, and we are monitoring the situation closely. We will provide additional updates as more information becomes available. (https://status.imperva.com/)
Posted May 28, 2026 - 15:59 EDT

Investigating

We are currently experiencing intermittent processing issues due to an issue with a third-party service provider. We are actively monitoring the situation with the provider and will share updates as they become available.
Posted May 28, 2026 - 14:23 EDT
This incident affected: PayConex.