PayConex Scheduled Maintenance
Completed
The scheduled maintenance has been completed.
Posted Oct 17, 2024 - 12:00 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 17, 2024 - 07:00 EDT
Scheduled
Bluefin will be conducting scheduled maintenance in the Production PayConex environment on Thursday, October 17, 2024, from 7:00 AM to 12:00 PM EST.

We do not anticipate any impact on service availability during this maintenance.

Should you experience any issues during this time, please contact our customer service and support staff for assistance at service@bluefin.com.
Posted Oct 04, 2024 - 09:37 EDT
This scheduled maintenance affected: PayConex.