intermittent Interruption

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 17:00 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 02, 2025 - 16:33 EDT

Investigating

We are aware of a third party service provide experiencing issues affecting customers on the west coast. We will provide further updates as more information becomes available. We apologize for the inconvenience and appreciate your patience.
Posted Apr 02, 2025 - 16:05 EDT
This incident affected: PayConex.