Resolved
This incident has been resolved.
Posted Sep 03, 2024 - 10:16 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2024 - 09:49 EDT
Investigating
We have detected a service interruption for P2PE Manager related to Decryptx software release. Our team of engineers is currently working to restore service as soon as possible. Please check back for further updates. We apologize for the inconvenience and we thank you for your patience.
Posted Sep 03, 2024 - 09:48 EDT
This incident affected: Decryptx.