Atlanta Data Center Maintenance

Completed

The scheduled maintenance has been completed.
Posted Aug 19, 2024 - 03:00 EDT

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 18, 2024 - 22:00 EDT

Scheduled

Bluefin intends to carry out maintenance in its Atlanta Data Center on Sunday 18 August 2024 at 10:00pm EDT. All services using the Internet for connectivity will be routed to the Tulsa Data Center prior to beginning the maintenance.
Posted Aug 13, 2024 - 17:00 EDT
This scheduled maintenance affected: PayConex, PayConex Plus, Bluefin Gateway, QuickSwipe Mobile, CardConex, SaaSConex, ShieldConex, Decryptx, and Certification/Integration/Test Platforms.