Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 10:55 EDT

Monitoring

We became aware of an issue affecting Payconex login services for some customers and have implemented a fix. Transaction processing is not affected. Our team is monitoring the service to ensure continued stability.

Please check back for further updates. We apologize for the inconvenience and thank you for your patience.
Posted Jul 09, 2026 - 10:24 EDT
This incident affected: PayConex.