Tulsa Data Center Maintenance

Completed

The scheduled maintenance has been completed.
Posted Aug 20, 2026 - 02:00 EDT

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 19, 2026 - 22:00 EDT

Scheduled

Tulsa Data Center Maintenance

Bluefin will be performing scheduled maintenance in its Tulsa Data Center on Wednesday 19 August 2026 at 9:00pm CDT.

To minimize customer impact, all internet-facing services will be routed to the Atlanta Data Center before maintenance begins. No interruption to service is expected during this maintenance window.

Thank you for your patience and understanding as we complete this maintenance.
Posted Aug 18, 2026 - 18:00 EDT
This scheduled maintenance affected: PayConex, PayConex Plus, Bluefin Gateway, QuickSwipe Mobile, CardConex, SaaSConex, ShieldConex, Decryptx, and Certification/Integration/Test Platforms.