Intermittent issues

Resolved

The third-party provider has confirmed that service in the affected data center has been restored to normal. This incident is now resolved. Thank you for your patience.
Posted Mar 13, 2025 - 17:53 EDT

Monitoring

A fix has been implemented by our third-party provider, and we are monitoring to ensure service stability. Impact to the North East US is expected to improve. We will provide a final update once the issue is confirmed fully resolved. Thank you for your patience.
Posted Mar 13, 2025 - 17:37 EDT

Update

This remains a third-party incident impacting the North East US. Our team continues to monitor the situation, and we will provide another update in 30 minutes. Thank you for your patience.
Posted Mar 13, 2025 - 17:26 EDT

Identified

identified as a 3rd party incident impacting North East US.
Our team of engineers have identified as a 3rd party incident impacting North East US.. Our next update will be in 30 minutes. We apologize for the inconvenience and we thank you for your patience.
Posted Mar 13, 2025 - 16:52 EDT

Investigating

We are investigating intermittent issues being reported on PCX from clients in the US northeast region.
Posted Mar 13, 2025 - 16:24 EDT
This incident affected: PayConex.