P2PE Manager loading issues
Incident Report for Bluefin Payment Systems
Resolved
Service has been fully restored. Thank you for your patience.
Posted Jun 30, 2020 - 20:32 EDT
Investigating
We have detected large increases in loading times while running specific queries on our P2PE device manager service. Decryption processing remains up and unaffected. Our team of engineers is currently working to restore functionality as soon as possible. Please check back for further updates. We apologize for the inconvenience and we thank you for your patience.
Posted Jun 30, 2020 - 16:53 EDT
This incident affected: Decryptx.