PayConex Software Release

Completed

The scheduled maintenance has been completed.
Posted Jan 29, 2025 - 09:00 EST

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 29, 2025 - 07:00 EST

Scheduled

Bluefin released a software update to the PayConex production environment on Monday, January 27, 2025, at 7:00 AM EST. During the release, we discovered a small issue and reverted PayConex back to the pre-release codebase to ensure stability.

The production release is now scheduled for Wednesday, January 29th, 2025, at 7:00 AM EST. There is no anticipated to impact to service availability.

If you experience any issues, please get in touch with our support staff for assistance.

Want to see what's new in PayConex?

Checkout the link to our release notes: PayConex - 01.27.2025
Posted Jan 28, 2025 - 14:12 EST
This scheduled maintenance affected: PayConex.