PayConex Software Release

Completed

The scheduled maintenance has been completed.
Posted Sep 04, 2025 - 10:10 EDT

Scheduled

The PayConex release to production is now active in all sites.

If you experience any issues, please get in touch with our support staff for assistance.

Want to see what's new in PayConex?

Checkout the link to our release notes: PayConex - 09.03.2025
Posted Sep 04, 2025 - 10:04 EDT
This scheduled maintenance affected: PayConex.