Resolved

This incident has been resolved. We thank you for your patience.
Posted Jul 28, 2026 - 10:15 EDT

Monitoring

We have detected a service interruption for the P2PEManager. Our team of engineers have applied a fix and are currently monitoring. Please check back for further updates. We apologize for the inconvenience and we thank you for your patience.
Posted Jul 28, 2026 - 09:31 EDT
This incident affected: Decryptx.