Tulsa Data Center Maintenance
Completed
The scheduled maintenance has been completed.
Posted Oct 13, 2024 - 01:00 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 12, 2024 - 22:00 EDT
Scheduled
Bluefin intends to carry out maintenance in its Tulsa Data Center on Saturday 12 October 2024 at 9:00pm CDT. All services using the Internet for connectivity will be routed to the Atlanta Data Center prior to beginning the maintenance.
Posted Oct 11, 2024 - 11:54 EDT
This scheduled maintenance affected: PayConex, PayConex Plus, Bluefin Gateway, QuickSwipe Mobile, CardConex, SaaSConex, ShieldConex, Decryptx, and Certification/Integration/Test Platforms.