Processing Issue
Incident Report for Bluefin Payment Systems
Resolved
The disruption to American Express transaction processing through our platform has been resolved. The incident was caused by an internal problem at a third party.

PayConex is fully operational and processing without issue.
Posted Jun 17, 2021 - 16:44 EDT
Investigating
We are investigating reports of processing issues affecting merchants using our PayConex platform. Our team of engineers is currently working to fix the issue as soon as possible. Please check back for further updates. We apologize for the inconvenience and we thank you for your patience.
Posted Jun 17, 2021 - 15:34 EDT
This incident affected: PayConex.