Resolved
This incident is now resolved.
Posted Nov 24, 2023 - 19:09 EST
Monitoring
Our monitoring systems identified a widespread issue impacting the processing of Visa card transactions, which persisted until 40 minutes ago. It's crucial to note that this incident wasn't exclusive to Elavon but rather affected various service providers across the board.
Posted Nov 24, 2023 - 18:05 EST
Investigating
We are investigating reports of processing issues affecting merchants utilizing our Elavon processing interface. Our team of engineers is working with our contacts at Elavon to find a solution. Please check back for further updates. We apologize for the inconvenience and we thank you for your patience.
Posted Nov 24, 2023 - 17:26 EST
This incident affected: PayConex.