intermittent Interruption

Resolved

This incident has been resolved.
Posted May 14, 2025 - 13:26 EDT

Monitoring

We have identified intermittent service disruptions through a third-party provider. Our engineering team is actively investigating the root cause and working to mitigate any impact. We will provide further updates as more information becomes available. We apologize for the inconvenience and appreciate your patience.
Posted May 14, 2025 - 12:51 EDT
This incident affected: PayConex.