3rd Party Incident
Resolved
This incident has been resolved.
Posted Sep 26, 2024 - 18:32 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 26, 2024 - 16:44 EDT
Update
We are continuing to investigate this issue.
Posted Sep 26, 2024 - 15:21 EDT
Investigating
Bluefin is aware of an issue with merchants processing on TSYS. TSYS is working to restore service as quickly as possible. We apologize for any inconvenience caused and sincerely appreciate your patience during this time
Posted Sep 26, 2024 - 12:58 EDT
This incident affected: PayConex.