Phone System Outage

Resolved

This incident has been resolved.
Posted Aug 05, 2025 - 21:15 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 05, 2025 - 18:36 EDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 05, 2025 - 17:32 EDT

Identified

We want to inform you that our phone system provider is currently experiencing a widespread service disruption affecting both inbound and outbound calling.

This issue stems from a Core Voice incident on their end, and unfortunately, it is also impacting our internal operations—many of our team members are unable to make or receive calls at this time.

The provider has identified the root cause and is actively working to deploy a fix to restore service as soon as possible. As of now, there is no available workaround.

In the meantime, you can still reach us via email:
- Technical Support: techsupport@bluefin.com
- Customer Service: service@bluefin.com

We understand the inconvenience this may cause and sincerely appreciate your patience and understanding while the issue is being resolved.
Posted Aug 05, 2025 - 17:32 EDT
This incident affected: Bluefin US.