3rd Party Incident

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 07:39 EDT

Identified

Bluefin is aware of an issue with merchants processing on Vital. Vital is working to restore service as quickly as possible. We apologize for any inconvenience caused and sincerely appreciate your patience during this time
Posted Aug 21, 2025 - 07:07 EDT
This incident affected: PayConex.