Decrytpx Update
Completed
The scheduled maintenance has been completed.
Posted Oct 27, 2020 - 07:00 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 27, 2020 - 06:00 EDT
Scheduled
Bluefin will be updating the Decryptx P2PE Manager interface on Tuesday, Oct 27th. This update will change the P2PE Manager Device tab to improve speed and efficiency of searches. We do not anticipate any impact to decryption processing. Reach out to support if you suspect your device can't be found or is not processing correctly
Posted Oct 21, 2020 - 11:22 EDT
This scheduled maintenance affected: Decryptx.