Customer Funding Advisory – Processor

Resolved

This incident has been resolved.
Posted Jan 28, 2026 - 07:40 EST

Update

Elavon have resolved the issues. Affected customers may see see funding delayed by up to 24 hours as transactions Finalize.
Posted Jan 27, 2026 - 12:39 EST

Monitoring

Elavon has informed us that a solution has been successfully implemented. Our team is actively monitoring the outcomes to ensure that the fix is effective and that everything is functioning as intended. We appreciate your patience during this process.
Posted Jan 27, 2026 - 05:23 EST

Update

Elavon are continuing to investigate the issue.
Posted Jan 26, 2026 - 17:52 EST

Investigating

Bluefin has been informed by Elavon that settlement activity has been delayed for merchants processing with Elavon.
https://status.elavon.com/issues/697780f110bdfb715d5dc44c


Bluefin will provide additional updates as they are received. We apologize for the inconvenience and appreciate your patience.
Posted Jan 26, 2026 - 12:09 EST
This incident affected: PayConex.