Scheduled Maintenance Notice – CardConex Platform

Completed

The scheduled maintenance has been completed.
Posted Jun 28, 2025 - 10:00 EDT

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 28, 2025 - 06:00 EDT

Scheduled

Please be advised that Bluefin will be performing scheduled maintenance on the CardConex (SFTP file transfer) system on Saturday, 28 June 2025, from 06:00 AM to 10:00 AM EDT.
During this maintenance window, file transfers (uploads and downloads) via SFTP will be temporarily unavailable. Please note that payment processing will not be impacted and will continue to function normally.
Thank you for your understanding and continued support.
Posted Jun 24, 2025 - 17:27 EDT
This scheduled maintenance affected: CardConex.