External Processor issue
Incident Report for Bluefin Payment Systems
Resolved
This incident has been resolved.
Posted Jun 18, 2021 - 08:14 EDT
Investigating
We are investigating reports of processing issues at a third-party processor affecting only a select group of merchants utilizing the Bluefin Gateway. Our team of engineers is working with our contacts at the third-party processor to find a solution. We apologize for the inconvenience and we thank you for your patience.
Posted Jun 18, 2021 - 08:00 EDT
This incident affected: PayConex.