Sporadic Interruption

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 10:53 EDT

Monitoring

We have detected service interruption when processing transactions from 8:40 CT to 8:53 CT. Our team of engineers are currently investigating the root cause of the problems and working to minimize impact. Please check back here for further updates. We apologize for the inconvenience and we thank you for your patience.
Posted Jul 14, 2025 - 10:26 EDT
This incident affected: PayConex.