Resolved
This incident has been Resolved
Posted Mar 28, 2024 - 21:33 EDT
Monitoring
A fix has been implemented and we are now monitoring
Posted Mar 28, 2024 - 20:27 EDT
Update
We are continuing to work on a fix for this issue with Ezic.
Posted Mar 28, 2024 - 19:06 EDT
Identified
Our engineering team has been informed by Ezic that the processing issues affecting a select group of merchants utilizing the Bluefin Gateway are a result of emergency maintenance. Ezic is actively working to restore service as quickly as possible. We apologize for any inconvenience caused and sincerely appreciate your patience during this time.
Posted Mar 28, 2024 - 17:36 EDT
Investigating
We are investigating reports of processing issues at Ezic affecting only a select group of merchants utilizing the Bluefin Gateway. Our team of engineers is working with our contacts at Ezic to find a solution. We apologize for the inconvenience and we thank you for your patience.
Posted Mar 28, 2024 - 17:07 EDT
This incident affected: Bluefin Gateway.