Service Interruption
Resolved
Service has been fully restored. Thank you for your patience.
Posted Dec 03, 2019 - 04:52 EST
Update
We are continuing to investigate this issue.
Posted Dec 03, 2019 - 04:07 EST
Investigating
We have detected a service interruption for Cardconex. Our team of engineers is currently working to restore service as soon as possible. Please check back for further updates. We apologize for the inconvenience and we thank you for your patience.
Posted Dec 03, 2019 - 04:05 EST
This incident affected: CardConex.