Service Issue PayConex
Resolved
This incident has been resolved.
Posted Dec 07, 2023 - 17:14 EST
Update
We are continuing to work on a fix for this issue.
Posted Dec 07, 2023 - 16:08 EST
Update
We are continuing to work on a fix for this issue.
Posted Dec 07, 2023 - 15:08 EST
Update
We are continuing to work on a fix for this issue.
Posted Dec 07, 2023 - 13:15 EST
Identified
We have identified the issues and are working to correct impacted terminals.
Posted Dec 07, 2023 - 12:03 EST
Investigating
We have detected a service interruption for the PayConex system. . Our team of engineers is currently working to restore service as soon as possible. Please check back for further updates. We apologize for the inconvenience and we thank you for your patience.
Posted Dec 07, 2023 - 11:27 EST
This incident affected: PayConex.