Scheduled Maintenance
Completed
The scheduled maintenance has been completed.
Posted May 11, 2018 - 11:12 EDT
Scheduled
Bluefin will be releasing a software update to the Production PayConex gateway on Thursday 10/5/17 at 06:00 AM CDT. The maintenance activity is not anticipated to impact service availability. If you have any questions regarding this maintenance, please contact your relationship team.
Posted Oct 02, 2017 - 09:50 EDT
This scheduled maintenance affected: PayConex.