Scheduled Maintenance
Completed
The scheduled maintenance has been completed.
Posted Jul 13, 2017 - 07:30 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 13, 2017 - 07:00 EDT
Scheduled
Bluefin will be performing routine maintenance to the PayConex Gateway on Thursday 7/13/17 from 06:00 to 06:30 AM CDT. The maintenance activity is not anticipated to impact service availability. If you have any questions regarding this maintenance, please contact your relationship team.
Posted Jul 11, 2017 - 10:01 EDT
This scheduled maintenance affected: PayConex.