Software Release
Completed
The scheduled maintenance has been completed.
Posted May 11, 2018 - 11:10 EDT
Scheduled
Bluefin will be releasing a software update to the Production PayConex gateway on Wednesday January 24th, 2018 at 06:00 CDT.The maintenance activity is not anticipated to impact service availability. If you have any questions regarding this maintenance, please contact your Bluefin support team.
Posted Jan 16, 2018 - 15:49 EST
This scheduled maintenance affected: PayConex.