Software Release
Completed
The scheduled maintenance has been completed.
Posted May 11, 2018 - 11:10 EDT
Scheduled
As Bluefin continues to lead, innovate and deliver secure payment transaction solutions, we will be releasing a software update to the Production PayConex gateway on Thursday 12/7/17 at 06:00 CDT. The software update includes new features and brings the system software up to the most current industry standard version. The maintenance activity is not anticipated to impact service availability. If you have any questions regarding this maintenance, please contact your relationship team.
Posted Dec 04, 2017 - 16:00 EST
This scheduled maintenance affected: PayConex.