Decryptx 2.1 Release
Completed
The scheduled maintenance has been completed.
Posted Dec 10, 2019 - 08:30 EST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 10, 2019 - 07:00 EST
Scheduled
Bluefin will be releasing version 2.1 of Decryptx on Tuesday, December 10th. This update will not impact decryption processing. A summary of updates follow.

- Device Activity Report – updated to display first and last activity dates correctly.

- AES Encryption – Decryptx has been updated to support AES cryptography. Device manufactures will move to this stronger cryptography in their terminals over time.

- P2PE Manager update to optionally hide transaction, other reporting and equipment ordering. To be used in conjunction with custom branding.

- Dashboard – Device Location widget update.

- Added a filter to Attestations page to only show devices which have attestations in the future.

- Updated Node.js to v10+ as part of the release.

- Client file import process improved.

- Streamlined Sub-Partner creation to optionally pull the default user from the Parent Partner.

- Device Audit Summary added to the dashboard. This will enable users to see the audit summary and associated severity. This can be an indicator to Partners and Clients on their Decryptx processing and any associated issues.

- Default Page – Users can now select their default landing page upon login. This will let the User go directly to their most used page automatically.

- Decoupled the requirement to receive all devices in a shipment before any device can be put in an activating state.

- Removed the requirement to add a Partner ID and Billing ID for Sub-Partners.

- Added search capability to audit logs by serial number or Client name. This is useful for troubleshooting errors related to a Client or a device.

- Other minor bug fixes
Posted Dec 02, 2019 - 20:47 EST
This scheduled maintenance affected: Decryptx.