P2PE Manager Update
Completed
The scheduled maintenance has been completed.
Posted Jul 18, 2017 - 08:30 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 18, 2017 - 08:00 EDT
Scheduled
Bluefin will be performing routine maintenance to the Decryptx P2PE Manager on 07/18/2017 from 0700 to 0730 AM CDT. The maintenance activity is not anticipated to impact service availability. Bluefin will be enhancing the Virtual Device Sharing capabilities of the P2PE Manager. If you have any questions regarding this maintenance, please contact your relationship team.
Posted Jul 11, 2017 - 17:53 EDT
This scheduled maintenance affected: Decryptx.