Identified - Our engineering team has been informed by Ezic that the processing issues affecting a select group of merchants utilizing the Bluefin Gateway are a result of emergency maintenance. Ezic is actively working to restore service as quickly as possible. We apologize for any inconvenience caused and sincerely appreciate your patience during this time.
Mar 28, 2024 - 17:36 EDT
Investigating - We are investigating reports of processing issues at Ezic affecting only a select group of merchants utilizing the Bluefin Gateway. Our team of engineers is working with our contacts at Ezic to find a solution. We apologize for the inconvenience and we thank you for your patience.
Mar 28, 2024 - 17:07 EDT

About This Site

Keep up-to-date with Bluefin's system updates for operational and product status. Stay informed of any incidents or alerts affecting payment processing now.

PayConex ? Operational
PayConex Plus ? Operational
Bluefin Gateway ? Major Outage
QuickSwipe Mobile ? Operational
CardConex ? Operational
SaaSConex Operational
ShieldConex ? Operational
Decryptx ? Operational
Bluefin US Operational
Certification/Integration/Test Platforms ? Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Past Incidents
Mar 28, 2024

Unresolved incident: Processing Issue.

Mar 27, 2024

No incidents reported.

Mar 26, 2024

No incidents reported.

Mar 25, 2024
Resolved - Issue has been resolved.
Mar 25, 17:58 EDT
Update - Our team of engineers have identified the issue and are working on a resolution. We apologize for the inconvenience and we thank you for your patience.
Mar 25, 07:14 EDT
Identified - Our team of engineers have identified the issue and are working on a resolution.
Please bear with us while we provide you with an update soon.
We apologize for the inconvenience, and we thank you for your patience.

Mar 25, 02:09 EDT
Update - Our team of engineers continue to investigate this issue.
We will update you soon on this matter.
Apologies for the inconvenience, and we thank you for your patience.

Mar 24, 23:39 EDT
Update - Our team of engineers continue to investigate this issue. Our next update will be in 30 minutes. We apologize for the inconvenience and we thank you for your patience.
Mar 24, 21:03 EDT
Investigating - Mozilla published an update to their Firefox browser which has caused an interoperability issue with SaaSConex. Google Chrome and Microsoft Edge browsers will work as replacements in the interim. Bluefin is investigating the Firefox changes for resolution.
Mar 24, 17:37 EDT
Mar 24, 2024
Mar 23, 2024

No incidents reported.

Mar 22, 2024

No incidents reported.

Mar 21, 2024

No incidents reported.

Mar 20, 2024

No incidents reported.

Mar 19, 2024
Completed - The scheduled maintenance has been completed.
Mar 19, 10:00 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 19, 07:00 EDT
Update - We will be undergoing scheduled maintenance during this time.
Mar 5, 06:51 EST
Scheduled - Bluefin will be releasing a software update to the Production ShieldConex environment on Thursday 03/19/2024 from 07:00 am to 10:00 am EST. The software release to Production is not anticipated to impact service availability. This software update is currently deployed in our Certification environment. We encourage our partners to perform acceptance testing against this software update in our Certification environment before the Production release date. If you experience any issues, please get in touch with our support staff for assistance.

Click the link below to check out what's new in ShieldConex.

ShieldConex® v1.15 Release Notes

Feb 13, 17:09 EST
Mar 18, 2024
Completed - The scheduled maintenance has been completed.
Mar 18, 04:00 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 17, 22:00 EDT
Scheduled - Bluefin intends to carry out maintenance in its Atlanta Data Center on Sunday 17 March 2024 at 10:00pm EDT. All services using the Internet for connectivity will be routed to the Tulsa Data Center prior to beginning the maintenance.
Mar 13, 12:53 EDT
Mar 17, 2024
Mar 16, 2024

No incidents reported.

Mar 15, 2024

No incidents reported.

Mar 14, 2024
Resolved - Service has been fully restored. Thank you for your patience.
Mar 14, 21:57 EDT
Update - As of 20:22 CT Ezic have told us that all gateways are now fully operational now.
Mar 14, 21:30 EDT
Update - Ezic's engineering team is continuing to work on a solution. We apologize for any inconvenience caused and sincerely appreciate your patience during this process.
Mar 14, 19:51 EDT
Update - Ezic's engineering team is continuing to work on a solution. We apologize for any inconvenience caused and sincerely appreciate your patience during this process.
Mar 14, 17:58 EDT
Update - Ezic's engineering team has pinpointed the problem and is actively pursuing a solution. We apologize for any inconvenience caused and sincerely appreciate your patience during this process.
Mar 14, 14:49 EDT
Update - Ezic's team of engineers have identified the issue and are working on a resolution. We apologize for the inconvenience and we thank you for your patience.
Mar 14, 12:40 EDT
Update - Ezics team of engineers have identified the issue and are working on a resolution. Have emailed and called to follow up for a rough ETA. We apologize for the inconvenience and we thank you for your patience.
Mar 14, 11:01 EDT
Identified - Ezics team of engineers have identified the issue and are working on a resolution. We apologize for the inconvenience and we thank you for your patience.
Mar 14, 08:23 EDT
Update - Ezics team of engineers continue to investigate this issue. We apologize for the inconvenience and we thank you for your patience.
Mar 14, 06:33 EDT
Investigating - We are investigating reports of processing issues at Ezic affecting only a select group of merchants utilizing the Bluefin Gateway. Our team of engineers is working with our contacts at Ezic to find a solution. We apologize for the inconvenience and we thank you for your patience.
Mar 14, 04:38 EDT