Scheduled Maintenance Notice – PayConex Platform

Completed

The scheduled maintenance has been completed.
Posted Oct 09, 2025 - 10:00 EDT

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 09, 2025 - 06:00 EDT

Scheduled

Please be advised that Bluefin will be performing scheduled maintenance on the PayConex system on Thursday, 9 October 2025, from 06:00 AM to 10:00 AM EDT.

Please note that during this maintenance period the PayConex website and payment processing will not be impacted and will continue to function normally.

Thank you for your understanding and continued support.
Posted Oct 02, 2025 - 10:09 EDT
This scheduled maintenance affected: PayConex.