Resolved
This incident has been resolved, apologies for the inconvenice. Please feel free to call or email about any technical problems caused by this outage.
Posted Nov 18, 2022 - 20:48 EST
Update
We are continuing to investigate this issue.
Posted Nov 18, 2022 - 20:28 EST
Investigating
We are investigating reports of processing issues affecting merchants utilizing American Express for processing payments. Our team of engineers is working with our contacts at American Express to find a solution. Please check back for further updates. We apologize for the inconvenience and we thank you for your patience.
Posted Nov 18, 2022 - 20:21 EST
This incident affected: PayConex.