Decryptx/P2PE Manager Maintenance
Completed
The scheduled maintenance has been completed.
Posted Aug 13, 2019 - 08:30 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 13, 2019 - 07:00 EDT
Scheduled
Bluefin will be releasing a software update to our Production Decryptx/P2PE Manager Environment on 08/13/19 at 0600 AM Central. This release does not impact the core decryption processing or management API’s. Those integrated to Decryptx should see no change in their processing. Decryption processing will not be impacted.

The software updates will include the following enhancements:

- change of password experience flow
- hyperlinking device attestation due dates to the update record
- updated logging
- new filter to display "All" or "Active" or "Non-Active" by devices state
- dashboard improvements
- performance enhancements
- Other minor bug fixes/enhancements
Posted Aug 08, 2019 - 12:12 EDT
This scheduled maintenance affected: Decryptx.